WebLink Help Center | Security Certificate | TLS version 1.2 Required

What is changing?

In our continuing effort to protect your data, Zendesk/WebLink Help Center is updating the minimum allowed TLS version for connecting securely to the WebLink Help Center.  The new minimum allowed version is TLS 1.2.

 

When does this change take affect?

June 14, 2018

 

What do I need to do?

When going to www.weblinksupport.com, be sure you are using an Internet Browser that supports TLS 1.2.

 

What Internet Browsers support TLS 1.2?

The minimum browser versions include browsers such as Internet Explorer 11, Mozilla Firefox 27, Google Chrome 30 or Apple Safari 7. iOS 5.1 and Android 5 Lollipop or later will be required to connect to the mobile web versions of the products.  Basically, if you are using Google Chrome or Mozilla Firefox, that automatically updates, you should see no interruption.

 

I can't upgrade or install another browser, what happens now?

You may not be able to connect to the WebLink Help Center and login because your browser may show a warning that the security certificate cannot be verified on the older TLS connection.

 

Where can I download a supported Internet Browser right now?

Google Chrome - https://www.google.com/chrome/ 

Mozilla Firefox - https://www.mozilla.org/en-US/firefox/new/ 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.

Want some training on WebLink Connect? Sign up today for one of our upcoming online training classes.